Hack to get Selenium IDE running on Firefox 4

With Firefox 4 being just out, the Selenium team hasn’t had a chance to update their Add-on packaging for the release Firefox version (although I see it’s been tested on the beta version).

So I manually hacked the RDF files for the v1.0.10 IDE and PHP formatter, to get up and running. You’ll need to unzip the attached file, then manually install each of the two XPI Add-on files by going to the Add-ons Manager and choosing “Install Add-on From File…” – click the button to the left of the search box to get the menu.

No ill effects I can tell, but use with caution. I assume this will be fixed in 1.0.11 in the coming weeks, but this should work in the meantime.

hacked_selenium_ide_and_php_xpis.zip

3 thoughts on “Hack to get Selenium IDE running on Firefox 4”

  1. Hi,

    Thanks for posting this article. I tried to install the add ons by downloading the zip file and extracting those 2 files.

    I still get the same error (not compatible with Firefox), I am running Windows 7 Firefox 4.0.1.

    Any help is appreciated.

    Thanks
    Ravi

  2. Vincent- That bug is actually not related to this post, but it’s caused by Facebook throwing errors that show up in IE if you are debugging. There is a later reply to the thread that provides a workaround (turn on compatibility mode). It’s still pretty broken IMO.

    Ravi- You’ll get that error on Firefox 4.0.1 since I only updated the XPI’s to support Firefox 4.0 (the latest version at the time). Best to wait until the Selenium team updates their code, which should happen pretty soon.

Leave a Reply

Your email address will not be published. Required fields are marked *